Monday, September 17, 2012

When things go Wrong - Error registering table GL_Account_MSTR

Here's what happened.





 



You've just installed the workstation, you launch it and are greeted with this:


What to do?
You'll be delighted to know that this is an easy fix. The problem comes up when folks copy the Dynamics.set file to one worksation from another before they synchronize the existing Dynamics.dic to the systems account framework.

All you need to do is change the the dex.ini file so that the following entry exists:

Synchronize=TRUE

Most likely, yours says FALSE

You need to make sure you only have one of these entries in your Dex.ini file. If you have more than one, the first one rules.

After you change the Dex.ini setting ( in the Data folder of your application folder), you'll need to launch Dynamics Utilities in order to complete the synchronization process.

Once the synchronization process is complete, the error should go away and Dynamics GP should launch.

Don't ya' love all of the 'should's' in that dialog?

Until next post!

Leslie

Thanks to David Musgrave's keen eye I changed this post to the correct setting. I had it backward originally. Unforgivable for the dex.ini queen.



1 comment:

David Musgrave said...

Hi Leslie

You need to change the Dex.ini setting to

Synchronize=TRUE

This will force the Utilities to run and match the Account Framework in the Dynamics.dic dictionary to the settings in the tables.

Note: If the settings in the table have been altered and are different from the actual account framework in the GL_Account_MSTR (GL00100) table, you will still have issues.

David
http://blogs.msdn.com/DevelopingForDynamicsGP/